Server degredation

Major incident Web Email Payments Scanning
2022-11-13 07:00 CEST · 9 hours, 1 minute

Updates

Issue

Billetto is investigating an issue that is causing issues with payments and other services.

14:30 servers begin to return to normal

November 13, 2022 · 14:28 CEST
De-escalate

Issue has been found and stability returning to normal

November 13, 2022 · 14:27 CEST

← Back